J10 ACR Problems

Hi all, need some help with my J10. bought it and modded it with:

green o ring
new nozzle + head
inner barrel + j10 t piece
hop up

Somehow the gels isnt moving while blasting. checked it at full mag & half mag. checked it blaster & mag individually, mag works fine with a simple battery test, tried aligning t piece and gearbox while placing 1 gel into the t piece and blast, it works.

appreciate your input here. thanks!

*edit: tried again, J10 magazine will shoot about 10 gels and problem above comes again. but gen 8 magazine working fine. hmmmm…

@MaybeMY Check the size of your balls. :roll_eyes: (@Calcifer don’t. Just don’t :rofl:)

They might be too small for the mag to pick up and feed.

If you’re using the ones that came with the blaster, they are usually crap.
Did you soak them long enough? (@Calcifer - seriously dude, move along. Nothing here to see :rofl::rofl:)

1 Like

Well tried with milkies and std orange ones… soaked for at least a good 4 hours hahaha

J10 mags suck, get some Gen9 mags

1 Like

Yeah solved with gen8 mag hahaha thanks guys

1 Like