LDT MP5 issues out of the box (RESOLVED)

Hi all,

Ok, I purchased a Metal S/S from X-ForceTactical and it arrived on Tuesday. It looked so lovely OTB - test fired it and the FPS was no where near what I expected and gels will also sometimes just blowing apart out the barrel. Now, I have lots of other blasters including the Cyma M16A1 metal and have upgraded my other JM blasters so I thought, too hard to post back so open it up. Below is the email I sent to X-Force


To X-Force

Hi Guys,

Got the MP5 and love it however, have/had a few issues.

Got to try it out and found the FPS was really bad – tried different Gels, Milkies but mainly Ultra Elites and same results. Some gels were disintegrating coming out the barrel.

As I am up in Gympie and sending it back would be a pain and I have taken apart Gel Blasters a fair bit (this is my 10th toy). I had already watched Low Guido videos before purchase so I took it apart. Easy to strip down from those bloody mag springs but not too bad when you know how.

Anyway, I found several things.

  1. The FPS issue is due to the nozzle, its malformed. Crushed a bit and more oval than round. This is my main issue.

Other things you should be aware of:
2. Found the positive battery cable had the insulation crushed/bare just before it exits to the front Hand Guard. Due to this, I have replaced the wire with quality Silicon and routed to the stock now. This was a potential serious issue if it shorted on the metal case.

  1. When taking it apart, the fire/safety selector base (the plastic part in the ■■■) was upside down. God knows how it was working. In the factory they have just jammed on the outer selector handle and tightened up the grub screw. That would explain my initial disappoint with it out of the box as it was spongy and didn’t click on the dents. I put it back correctly now and now not an issue and works very nicely now.

So, my only problem really is the bad nozzle but no one in Gympie has them for an LTD.

Pictures attached.


XFORCE REPLY
Hey

Glad to hear you sorted out the wiring issues, in regards to the nozzle you can use the ones we’ve linked in this email as a direct drop in.

Kind regards
Xforce


ME
Hi,

Yeah, thanks but it was faulty out of the box.


XFORCE REPLY
Unfortunately you have voided your warranty by opening it mate under our policy we cannot honour it


ME
Ok, seriously, I identify the issue by opening it up and FIXING a potential LIPO fire issue with wiring first then find the stock nozzle is defective plus selector issue and you go warranty void. Will be putting this up on the forum for comment.


Ok, I do see their conditions but when I have had issues with other blasters, the Vendors have all been if I can identify the issue with just a small part needed, they have sent it out rather than me having to post back the whole blaster.

Whats everone’s thoughts?

Pictures - only have a photo of a piece of the broken wire. It was up just inside the casing before coming out the front handgrip hole under the barrel



Yikes

They are usually better than that

I’m about to take my MP5 to tambourine for its post purchase flogging… Starting to wonder

Initial inspection for me did not show those issues.

Hope the get you sorted

:thinking:

You know I hate to not give you the answer you might be seeking, but I think X-Force is maybe 99.9% right on this one. Like it’s pretty clearly stated that opening the shell is an immediate warranty voiding. They also don’t have any modding instructional videos to muddy the waters on that front.

However. Nylon nozzles are like. $5? There might even be some lying around the shop after upgrading stuff? @Vas_Opr should maybe toss one your way if he’s feeling charitable. Assuming this is 100% of your communication, you haven’t been rude or anything.

1 Like

Defective goods must be replaced. The “open the box” stuff is pure retail fallacy and bullshit. If the goods were defective then you are entitled to their replacement or a refund.

Agreed. These devices are not terribly intricate and the issues are not caused by his actions.

They’ve honoured warranty in similar situations previously

Hi Jazzy,

Yeah, I realise the warranty void but, like you said, I expected a replacement silicon nozzle chucked in an envelope for me to glue on.

And, No, I was not rude and that is the emails chain (well I fixed a typo in my last reply but nothing rude/amended)

1 Like

Honestly, I was glad I opened it up and found the bare wires. That could have been very serious. Now, I am an RC Plane nut and have been dealing with Battery, LiPo, wiring for over 20+ years. And I’m talking up to 6s 4000mah (half the size of a house brick) so very respectful of how dangerous they can be. Never had one of mine go up but seen other guys go bang due to a crash. Scary stuff.

2 Likes

Was at the dump on the weekend. Saw a front-end loader run over a cordless drill that had been thrown in the pit with its battery. Bang! - flame, sparks and smoke flying out of it for over a minute. They had to turn on the sprinklers and break out the fire hoses. That smelt awesome - not.

Hey guys cheers for the tag I’ll get the boys to find a nozzle that fits and send it up to you. Need to excuse my boys cause they are just following protocol. Hit me up and just remind me cause I got a lot on this next 2 weeks and I tend to forget stuff. Sorry for the stuff around but we’ll sort it out 100%. Today might be a tough one cause we got the Double bell AK coming plus some more 98k gas so its gonna be a bit crazy but we’ll get it out asap.

4 Likes

Your website is down too. At least for me.

Thank you Vas. Do you want my original order number?

Working for me

Website didnt work for me too first time then I reloaded and it did.

btw I’ll be very happy to get the MP5 working well as my Son is coming up on the 17th and he’s keen to have a play with it. Mind you, he’s Army and fires the real deal’s of course but he does appreciate the blasters and he’s very keen to hold the MP5 and M16A1.

1 Like

I checked the website and works fine for me could be just the browser and cookies something the Web developer told me it messes up with people’s browsing.
I’ll talk to the boys when in they should know of this issue but do shoot me the order number just in case.

@Vas_Opr its 228460

Thanks again.

no worries have spoken to the guys and got em to send one out to you.

Vas now thats sorted and your here, you do any specials starting tommorow?

I can’t access the site either, used a checker and it said it was up, deleted the cookies and still nada… might try a reboot.

Yeah just put up a post. The website works fine for me try a different browser. NO idea why some guys have issues it’s strange. If it was across the board I’d understand it was us but when I test it works and people are putting orders through.

I think it has to do with people’s routers. I tried;

Flushing my DNS (Failed)
Switching browser (Failed)
Opening the site on my browser on my phone (Failed)
Opening the site on my phone on mobile data (Worked)
Using a VPN to open it on my desktop (Failed)
Restarting my router (Failed)
Basically putting my router back to factory settings without actually using the factory settings button (Failed)

So all signs point to it being the point of failure.

However just waiting like 6 hours made it work again.